package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^https?:\/\/(?:www\.)?twitter\.com\/(?:#!\/)?@?([^/?#]*)(?:[?#].*)?$`)
var str = `https://twitter.com/TeleFootball
https://twitter.com/GoalUSA
https://twitter.com/goal_intl
https://twitter.com/GoalItalia
https://twitter.com/TMuk_news
https://twitter.com/TMit_news
https://twitter.com/footballitalia
https://twitter.com/footballespana_
https://twitter.com/cmdotcom
https://twitter.com/24CalcioMercato
https://twitter.com/TuttoMercatoWeb
https://twitter.com/GFN_France
https://twitter.com/TopMercato
https://twitter.com/sambafoot
https://twitter.com/WhoScored
https://twitter.com/fantagazzetta?original_referer=http%3A%2F%2Fwww.fantagazzetta.com%2F&profile_id=81810036&tw_i=618947696691384321&tw_p=embeddedtimeline&tw_w=329873702915276800
https://twitter.com/@UEFAcom
https://twitter.com/lestransferts
https://twitter.com/francefootball
https://twitter.com/footmercato
https://twitter.com/@FutbolFinanzas
https://twitter.com/MARCAinENGLISH
https://twitter.com/AS_Futbol
https://twitter.com/mundodeportivo
https://twitter.com/donbalon_com
https://twitter.com/insidewldftball
https://twitter.com/calciomercatoit
https://twitter.com/_football411
https://twitter.com/BBCFtbl
https://twitter.com/CNNFC
https://twitter.com/foxsoccer
https://twitter.com/ProSoccerTalk
https://twitter.com/beINSportsUSA
https://twitter.com/mirrorfootball
https://twitter.com/ESPNFC
https://twitter.com/DiMarzio
https://twitter.com/tribalfootball
https://twitter.com/WorldSoccerMag
https://twitter.com/SkyFootball
https://twitter.com/TheSunFootball
https://twitter.com/foot365
https://twitter.com/Mercato365
https://twitter.com/sofoot
https://twitter.com/abolapt
https://twitter.com/fanatikcomtr
https://twitter.com/kicker_bl_li
https://twitter.com/vi_nl
https://twitter.com/elfvoetbal
https://twitter.com/tipsbladet
https://twitter.com/KickOffMagazine
https://twitter.com/sportalkorea
https://twitter.com/Bundesliga_EN
https://twitter.com/FFScout
https://twitter.com/GAMBA_OFFICIAL
https://twitter.com/Squawka
https://twitter.com/StatsBomb
https://twitter.com/mediotiempo
https://twitter.com/soccerly`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}