#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^https?:\/\/(?:www\.)?twitter\.com\/(?:#!\/)?@?([^/?#]*)(?:[?#].*)?$"
Local $sString = "https://twitter.com/TeleFootball" & @CRLF & _
"https://twitter.com/GoalUSA" & @CRLF & _
"https://twitter.com/goal_intl" & @CRLF & _
"https://twitter.com/GoalItalia" & @CRLF & _
"https://twitter.com/TMuk_news" & @CRLF & _
"https://twitter.com/TMit_news" & @CRLF & _
"https://twitter.com/footballitalia" & @CRLF & _
"https://twitter.com/footballespana_" & @CRLF & _
"https://twitter.com/cmdotcom" & @CRLF & _
"https://twitter.com/24CalcioMercato" & @CRLF & _
"https://twitter.com/TuttoMercatoWeb" & @CRLF & _
"https://twitter.com/GFN_France" & @CRLF & _
"https://twitter.com/TopMercato" & @CRLF & _
"https://twitter.com/sambafoot" & @CRLF & _
"https://twitter.com/WhoScored" & @CRLF & _
"https://twitter.com/fantagazzetta?original_referer=http%3A%2F%2Fwww.fantagazzetta.com%2F&profile_id=81810036&tw_i=618947696691384321&tw_p=embeddedtimeline&tw_w=329873702915276800" & @CRLF & _
"https://twitter.com/@UEFAcom" & @CRLF & _
"https://twitter.com/lestransferts" & @CRLF & _
"https://twitter.com/francefootball " & @CRLF & _
"https://twitter.com/footmercato" & @CRLF & _
"https://twitter.com/@FutbolFinanzas" & @CRLF & _
"https://twitter.com/MARCAinENGLISH" & @CRLF & _
"https://twitter.com/AS_Futbol" & @CRLF & _
"https://twitter.com/mundodeportivo" & @CRLF & _
"https://twitter.com/donbalon_com" & @CRLF & _
"https://twitter.com/insidewldftball" & @CRLF & _
"https://twitter.com/calciomercatoit" & @CRLF & _
"https://twitter.com/_football411" & @CRLF & _
"https://twitter.com/BBCFtbl" & @CRLF & _
"https://twitter.com/CNNFC" & @CRLF & _
"https://twitter.com/foxsoccer" & @CRLF & _
"https://twitter.com/ProSoccerTalk" & @CRLF & _
"https://twitter.com/beINSportsUSA" & @CRLF & _
"https://twitter.com/mirrorfootball" & @CRLF & _
"https://twitter.com/ESPNFC" & @CRLF & _
"https://twitter.com/DiMarzio" & @CRLF & _
"https://twitter.com/tribalfootball" & @CRLF & _
"https://twitter.com/WorldSoccerMag" & @CRLF & _
"https://twitter.com/SkyFootball" & @CRLF & _
"https://twitter.com/TheSunFootball" & @CRLF & _
"https://twitter.com/foot365" & @CRLF & _
"https://twitter.com/Mercato365" & @CRLF & _
"https://twitter.com/sofoot" & @CRLF & _
"https://twitter.com/abolapt" & @CRLF & _
"https://twitter.com/fanatikcomtr" & @CRLF & _
"https://twitter.com/kicker_bl_li" & @CRLF & _
"https://twitter.com/vi_nl" & @CRLF & _
"https://twitter.com/elfvoetbal" & @CRLF & _
"https://twitter.com/tipsbladet" & @CRLF & _
"https://twitter.com/KickOffMagazine" & @CRLF & _
"https://twitter.com/sportalkorea" & @CRLF & _
"https://twitter.com/Bundesliga_EN" & @CRLF & _
"https://twitter.com/FFScout" & @CRLF & _
"https://twitter.com/GAMBA_OFFICIAL" & @CRLF & _
"https://twitter.com/Squawka" & @CRLF & _
"https://twitter.com/StatsBomb" & @CRLF & _
"https://twitter.com/mediotiempo" & @CRLF & _
"https://twitter.com/soccerly"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")