re = /[^?:\).{0,}](.+)/i
str = ')asdasdasads1212312314564561425346152435621456@@@@@'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end