const regex = /[^?:\).{0,}](.+)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^?:\\).{0,}](.+)', 'gi')
const str = `)asdasdasads1212312314564561425346152435621456@@@@@`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}