use strict;
my $str = '100% [Working]
100% [Packages 201 kB] [Waiting for headers]
100% [Waiting for headers]
100% [Packages 201 kB] [Waiting for headers]
100% [Sources 4,444 B] [Waiting for headers] [Waiting for headers]
100% [Packages 39.0 kB] [Waiting for headers] [Waiting for headers]
100% [Translation-en 904 kB] [Waiting for headers] [Waiting for headers]
10% [InRelease gpgv 64.5 kB] [Waiting for headers] [Waiting for headers] [Waiti
Reading package lists... 0%
Reading package lists... 0%
Reading package lists... 1%
Reading package lists... 6%
100% [Translation-en 4,149 kB] 17.4 MB/s 0s 100% [Working] 17.4 MB/s 0s 100%
[Translation-en 409 kB] 17.4 MB/s 0s 100% [Working] 17.4 MB/s 0s 100%
[Translation-en 21.2 kB] 17.4 MB/s 0s 100% [Working] 17.4 MB/s 0s 100%
[Translation-en 18.6 MB] 17.4 MB/s 0s 100% [Working] 17.4 MB/s 0s
100% [Working]
100% [Packages 201 kB] [Waiting for headers]
100% [Waiting for headers]
Hit http://us.archive.ubuntu.com trusty-backports/multiverse i386 Packages
100% [Working]
100% [Packages 3,341 B] [Waiting for headers]
100% [Waiting for headers]
Hit http://us.archive.ubuntu.com trusty-backports/main Translation-en
28% [Sources 507 kB] [1 InRelease 14.2 kB/64.4 kB 22%] [Waiting for headers] [W
28% [Sources 507 kB] [InRelease gpgv 15.4 kB] [1 InRelease 14.2 kB/64.4 kB 22%]
28% [Sources 507 kB] [InRelease gpgv 15.4 kB] [1 InRelease 14.2 kB/64.4 kB 22%]
91% [InRelease gpgv 15.4 kB] [1 InRelease 14.2 kB/64.4 kB 22%] [Waiting for hea
100% [Translation-en 363 kB] [4 Sources 221 kB/250 kB 89%] [Waiting for headers
100% [4 Sources 221 kB/250 kB 89%] [Waiting for headers] [5 Packages 17.0 kB/23';
my $regex = qr/(^(\d+%((?!\r\n)\s+))(\[((\w+)((\-\w+)?((?!\r\n)\s+)?(\w+)?((?!\r\n)\s+)?(\d+)?(\,)?(\d+)?(\.)?(\d?)((?!\r\n)\s+)?(k?B)?)?((?!\r\n)\s+)?(\w+)?\]))?(((((?!\r\n)\s+)\[)(.+)\])*(((?!\r\n)\s+)(\[)(.+))?(\r?\n)))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}