import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^(\\d+%((?!\\r\\n)\\s+))(\\[((\\w+)((\\-\\w+)?((?!\\r\\n)\\s+)?(\\w+)?((?!\\r\\n)\\s+)?(\\d+)?(\\,)?(\\d+)?(\\.)?(\\d?)((?!\\r\\n)\\s+)?(k?B)?)?((?!\\r\\n)\\s+)?(\\w+)?\\]))?(((((?!\\r\\n)\\s+)\\[)(.+)\\])*(((?!\\r\\n)\\s+)(\\[)(.+))?(\\r?\\n)))";
final String string = "100% [Working]\n\n"
+ "100% [Packages 201 kB] [Waiting for headers]\n\n"
+ "100% [Waiting for headers]\n\n"
+ "100% [Packages 201 kB] [Waiting for headers]\n\n"
+ "100% [Sources 4,444 B] [Waiting for headers] [Waiting for headers]\n\n"
+ "100% [Packages 39.0 kB] [Waiting for headers] [Waiting for headers]\n\n"
+ "100% [Translation-en 904 kB] [Waiting for headers] [Waiting for headers]\n\n"
+ "10% [InRelease gpgv 64.5 kB] [Waiting for headers] [Waiting for headers] [Waiti\n\n"
+ "Reading package lists... 0%\n\n"
+ "Reading package lists... 0%\n\n"
+ "Reading package lists... 1%\n\n"
+ "Reading package lists... 6%\n\n"
+ "100% [Translation-en 4,149 kB] 17.4 MB/s 0s 100% [Working] 17.4 MB/s 0s 100%\n"
+ "[Translation-en 409 kB] 17.4 MB/s 0s 100% [Working] 17.4 MB/s 0s 100%\n"
+ "[Translation-en 21.2 kB] 17.4 MB/s 0s 100% [Working] 17.4 MB/s 0s 100%\n"
+ "[Translation-en 18.6 MB] 17.4 MB/s 0s 100% [Working] 17.4 MB/s 0s\n\n"
+ "100% [Working]\n\n"
+ "100% [Packages 201 kB] [Waiting for headers]\n\n"
+ "100% [Waiting for headers]\n\n"
+ "Hit http://us.archive.ubuntu.com trusty-backports/multiverse i386 Packages\n\n\n"
+ "100% [Working]\n\n"
+ "100% [Packages 3,341 B] [Waiting for headers]\n\n"
+ "100% [Waiting for headers]\n\n"
+ "Hit http://us.archive.ubuntu.com trusty-backports/main Translation-en\n\n"
+ "28% [Sources 507 kB] [1 InRelease 14.2 kB/64.4 kB 22%] [Waiting for headers] [W\n"
+ "28% [Sources 507 kB] [InRelease gpgv 15.4 kB] [1 InRelease 14.2 kB/64.4 kB 22%]\n\n\n\n"
+ "28% [Sources 507 kB] [InRelease gpgv 15.4 kB] [1 InRelease 14.2 kB/64.4 kB 22%]\n"
+ "91% [InRelease gpgv 15.4 kB] [1 InRelease 14.2 kB/64.4 kB 22%] [Waiting for hea\n\n"
+ "100% [Translation-en 363 kB] [4 Sources 221 kB/250 kB 89%] [Waiting for headers\n"
+ "100% [4 Sources 221 kB/250 kB 89%] [Waiting for headers] [5 Packages 17.0 kB/23";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}