$re = '/^\+597[78]\d{6}$/m';
$str = '+5978567436';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);