package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\+597[78]\d{6}$`)
var str = `+5978567436`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}