import Foundation
let pattern = #"^(.*)(\/[0-9]+\/[a-z]+\-[a-z]+\/?.*)\/?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
https://localhost/produkter/mun-tander/40/currentprice-asc/activesubstances_paracetamol/freefrom_Parabener/producttypemouthandteeth_Munsk%C3%B6lj/
https://localhost/produkter/mun-tander/40/currentprice-asc
https://localhost/produkter/mun-tander/40/currentprice-asc/
https://localhost/produkter/mun-tander/40/currentprice-asc/content/img/ios-icon.png
https://localhost/produkter/mun-tander/count-40/sortby-currentprice_asc/filter-activesubstances_paracetamol-freefrom_Parabener-producttypemouthandteeth_Munsk%C3%B6lj/
https://localhost/produkter/mun-tander/count-40/sortby-currentprice_asc/filter-activesubstances_paracetamol/filter-freefrom_Parabener/filter-producttypemouthandteeth_Munsk%C3%B6lj/
https://localhost/produkter/mun-tander/count-40/sortby-currentprice_asc
https://localhost/produkter/mun-tander/count-40/sortby-currentprice_asc/
https://localhost/produkter/mun-tander/count-40/sortby-currentprice_asc/content/img/ios-icon.png
^(.*)\/count-([0-9]+)\/sortBy-([a-z]+)_([a-z]+)((\/filter-[^\/]+)+)?\/?
^(.*)(\/[0-9]+\/[a-z]+_[a-z]+\/?.*)\/?$
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)