$re = '/^(.*)(\/[0-9]+\/[a-z]+\-[a-z]+\/?.*)\/?$/mi';
$str = 'https://localhost/produkter/mun-tander/40/currentprice-asc/activesubstances_paracetamol/freefrom_Parabener/producttypemouthandteeth_Munsk%C3%B6lj/
https://localhost/produkter/mun-tander/40/currentprice-asc
https://localhost/produkter/mun-tander/40/currentprice-asc/
https://localhost/produkter/mun-tander/40/currentprice-asc/content/img/ios-icon.png
https://localhost/produkter/mun-tander/count-40/sortby-currentprice_asc/filter-activesubstances_paracetamol-freefrom_Parabener-producttypemouthandteeth_Munsk%C3%B6lj/
https://localhost/produkter/mun-tander/count-40/sortby-currentprice_asc/filter-activesubstances_paracetamol/filter-freefrom_Parabener/filter-producttypemouthandteeth_Munsk%C3%B6lj/
https://localhost/produkter/mun-tander/count-40/sortby-currentprice_asc
https://localhost/produkter/mun-tander/count-40/sortby-currentprice_asc/
https://localhost/produkter/mun-tander/count-40/sortby-currentprice_asc/content/img/ios-icon.png
^(.*)\\/count-([0-9]+)\\/sortBy-([a-z]+)_([a-z]+)((\\/filter-[^\\/]+)+)?\\/?
^(.*)(\\/[0-9]+\\/[a-z]+_[a-z]+\\/?.*)\\/?$';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);