import Foundation
let pattern = #"<blockquote[^>]*>((?>.|\s)+?)[^>]*<cite[^>]*>((?>.|\s)+?)<\/cite><\/blockquote>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<blockquote><p>simply dummy text of the printing and typesetting industry. Lorem Ipsum has been the industry's standard dummy text ever since the 1500s, when an unknown printer took a galley of type and scrambled it to make a type specimen book.</p><cite>John Doe</cite></blockquote>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}