const regex = /<blockquote[^>]*>((?>.|\s)+?)[^>]*<cite[^>]*>((?>.|\s)+?)<\/cite><\/blockquote>/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<blockquote[^>]*>((?>.|\\s)+?)[^>]*<cite[^>]*>((?>.|\\s)+?)<\\\/cite><\\\/blockquote>', '')
const str = `<blockquote><p>simply dummy text of the printing and typesetting industry. Lorem Ipsum has been the industry's standard dummy text ever since the 1500s, when an unknown printer took a galley of type and scrambled it to make a type specimen book.</p><cite>John Doe</cite></blockquote>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}