// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?uxm)(?(DEFINE)
(?<protocol> (?<=^|[^a-z]) [a-z]+? : )
(?<domain> (?:[a-z\-]+\.)+[a-z\-]+ )
(?<ip> (?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.){3}(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?) )
(?<port> (?<!\s):\d+(?=\/|$|\s))
(?<pathquery>[A-Za-z\d\!\*\(\)\;\:\@\&\=\+\$\,\/\?\#\[\]\%\{\}\|\\\^\`\~]+)
(?<url> (?&protocol) (?: (?:\/\/) (?: (?&domain) | (?&ip) ) (?&port)? )? (?&pathquery))
)
(?&url)").unwrap();
let string = "http://en.wikipedia.org/wiki/A#CITEREFSimpsonWeiner1989里面找 以上URL
下载地址magnet:?xt=urn:btih:65F16B126D8A656E4FC825DE204EBFAF04B070FC里面找 以上URL
magnet:
net:
以下URLhttps://en.wikipedia.org/wiki/A#CITEREFSimpsonWeiner1989里面找 以上URL
http://192.168.1.1/里面找
'https://en.wikipedia.org/wiki/A/////#CITEREFSimpsonWeiner1989'
http://192.168.1.1:80/ 里面找
以下URL
https://google.com/search?q=%E5%9F%9F%E5%90%8D#newwindow=1&q=%E5%9F%9F%E5%90%8D+%E5%AD%97%E7%AC%A6
http://en.wikipedia.org/wiki/A#CITEREFSimpsonWeiner1989
magnet:?xt=urn:btih:65F16B126D8A656E4FC825DE204EBFAF04B070FC
https://en.wikipedia.org/wiki/A#CITEREFSimpsonWeiner1989
http://192.168.1.1/
https://en.wikipedia.org/wiki/A/////#CITEREFSimpsonWeiner1989
http://192.168.1.1:80/
https://google.com/search?q=%E5%9F%9F%E5%90%8D#newwindow=1&q=%E5%9F%9F%E5%90%8D+%E5%AD%97%E7%AC%A6
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}