import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?(DEFINE)\n"
+ " (?<protocol> (?<=^|[^a-z]) [a-z]+? : )\n"
+ " (?<domain> (?:[a-z\\-]+\\.)+[a-z\\-]+ )\n"
+ " (?<ip> (?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\\.){3}(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?) )\n"
+ " (?<port> (?<!\\s):\\d+(?=\\/|$|\\s))\n"
+ " (?<pathquery>[A-Za-z\\d\\!\\*\\(\\)\\;\\:\\@\\&\\=\\+\\$\\,\\/\\?\\#\\[\\]\\%\\{\\}\\|\\\\\\^\\`\\~]+)\n"
+ " (?<url> (?&protocol) (?: (?:\\/\\/) (?: (?&domain) | (?&ip) ) (?&port)? )? (?&pathquery))\n"
+ ")\n"
+ "(?&url)";
final String string = "http://en.wikipedia.org/wiki/A#CITEREFSimpsonWeiner1989里面找 以上URL\n"
+ "下载地址magnet:?xt=urn:btih:65F16B126D8A656E4FC825DE204EBFAF04B070FC里面找 以上URL\n"
+ "magnet:\n"
+ "net:\n"
+ "以下URLhttps://en.wikipedia.org/wiki/A#CITEREFSimpsonWeiner1989里面找 以上URL\n"
+ "http://192.168.1.1/里面找\n"
+ "'https://en.wikipedia.org/wiki/A/////#CITEREFSimpsonWeiner1989'\n"
+ "http://192.168.1.1:80/ 里面找\n"
+ "以下URL\n"
+ "https://google.com/search?q=%E5%9F%9F%E5%90%8D#newwindow=1&q=%E5%9F%9F%E5%90%8D+%E5%AD%97%E7%AC%A6\n\n"
+ "http://en.wikipedia.org/wiki/A#CITEREFSimpsonWeiner1989\n"
+ "magnet:?xt=urn:btih:65F16B126D8A656E4FC825DE204EBFAF04B070FC\n"
+ "https://en.wikipedia.org/wiki/A#CITEREFSimpsonWeiner1989\n"
+ "http://192.168.1.1/\n"
+ "https://en.wikipedia.org/wiki/A/////#CITEREFSimpsonWeiner1989\n"
+ "http://192.168.1.1:80/\n"
+ "https://google.com/search?q=%E5%9F%9F%E5%90%8D#newwindow=1&q=%E5%9F%9F%E5%90%8D+%E5%AD%97%E7%AC%A6\n";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE | Pattern.COMMENTS | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}