re = /<a(?:.*\>)(.*)<\/a>/i
str = '<a>I don\'t want this</a>
startString
test1
<a>I want this1</a>
test2
<a>I want this2</a>
endString
gibberish
<a>I don\'t want this</a>
startString
test1
<a>I want this3</a>
test2
<a>I want this4</a>
endString
gibberish
<a>I don\'t want this</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end