import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a(?:.*\\>)(.*)<\\/a>";
final String string = "<a>I don't want this</a>\n"
+ "startString\n"
+ "test1\n"
+ "<a>I want this1</a>\n"
+ "test2\n"
+ "<a>I want this2</a>\n"
+ "endString\n"
+ "gibberish\n"
+ "<a>I don't want this</a>\n"
+ "startString\n"
+ "test1\n"
+ "<a>I want this3</a>\n"
+ "test2\n"
+ "<a>I want this4</a>\n"
+ "endString\n"
+ "gibberish\n"
+ "<a>I don't want this</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}