re = /(?<=^\$translateProvider\.translations\('de', {)[\s\S]*(?=}\)$)/
str = '$translateProvider.translations(\'de\', {
WASTE_MANAGEMENT: \'Abfallmanagement\',
WASTE_TYPE_LIST: \'Abfallarten\',
WASTE_ENTRY_LIST: \'Abfalleinträge\',
WASTE_TYPE: \'Abfallart\',
TREATMENT_TYPE: \'Behandlungsart\',
TREATMENT_TYPE_STATUS: \'Status Behandlungsart\',
DUPLICATED_TREATMENT_TYPE: \'Doppelte Behandlungsart\',
TREATMENT_TYPE_LIST: \'Behandlungsarten\',
TREATMENT_TARGET_LIST: \'Ziele Behandlungsarten\',
TREATMENT_TARGET_ADD: \'Ziel Behandlungsart hinzufügen\',
SITE_TARGET: \'Gebäudeziel\',
WASTE_TREATMENT_TYPES: \'Abfallbehandlungsarten\',
WASTE_TREATMENT_TARGETS: \'{{Abfallbehandlungsziele}}\',
WASTE_TREATMENT_TYPES_LIST: \'{{Abfallbehandlungsarten}}\',
WASTE_TYPE_ADD: \'Abfallart hinzufügen\',
UNIT_ADD: \'Einheit hinzufügen\'
})'
# Print the match result
str.match(re) do |match|
puts match.to_s
end