import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=^\\$translateProvider\\.translations\\('de', \\{)[\\s\\S]*(?=\\}\\)$)";
final String string = "$translateProvider.translations('de', {\n"
+ " WASTE_MANAGEMENT: 'Abfallmanagement',\n"
+ " WASTE_TYPE_LIST: 'Abfallarten',\n"
+ " WASTE_ENTRY_LIST: 'Abfalleinträge',\n"
+ " WASTE_TYPE: 'Abfallart',\n"
+ " TREATMENT_TYPE: 'Behandlungsart',\n"
+ " TREATMENT_TYPE_STATUS: 'Status Behandlungsart',\n"
+ " DUPLICATED_TREATMENT_TYPE: 'Doppelte Behandlungsart',\n"
+ " TREATMENT_TYPE_LIST: 'Behandlungsarten',\n"
+ " TREATMENT_TARGET_LIST: 'Ziele Behandlungsarten',\n"
+ " TREATMENT_TARGET_ADD: 'Ziel Behandlungsart hinzufügen',\n"
+ " SITE_TARGET: 'Gebäudeziel',\n"
+ " WASTE_TREATMENT_TYPES: 'Abfallbehandlungsarten',\n"
+ " WASTE_TREATMENT_TARGETS: '{{Abfallbehandlungsziele}}',\n"
+ " WASTE_TREATMENT_TYPES_LIST: '{{Abfallbehandlungsarten}}',\n"
+ " WASTE_TYPE_ADD: 'Abfallart hinzufügen',\n"
+ " UNIT_ADD: 'Einheit hinzufügen'\n"
+ "})";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}