$re = '/(\;?(3[0-9]{14}|[4-5][0-9]{15})=2[0-9](01|02|03|04|05|06|07|08|09|10|11|12)[1-2][0-6]{2}[a-zA-Z0-9 ]{7,13}\??)/m';
$str = '%B4455000000660490^FARNSWORTH/SHANE ^24102010001090100001?
B4455000000660490^FARNSWORTH/SHANE ^24102010001090100001
as4455000000660490=24102010001090100001as
av8r;4455000000660490=24102010001090100001?67ab67
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);