import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\;?(3[0-9]{14}|[4-5][0-9]{15})=2[0-9](01|02|03|04|05|06|07|08|09|10|11|12)[1-2][0-6]{2}[a-zA-Z0-9 ]{7,13}\\??)";
final String string = "%B4455000000660490^FARNSWORTH/SHANE ^24102010001090100001?\n"
+ "B4455000000660490^FARNSWORTH/SHANE ^24102010001090100001\n"
+ "as4455000000660490=24102010001090100001as\n"
+ "av8r;4455000000660490=24102010001090100001?67ab67\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}