# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\[(?P<timestamp>\d+-\d{2}-\d{2} \d{2}:\d{2}:\d{2},\d{3})\] (?P<level>[A-Z]+) \[(?P<context>.+?)\] (?P<msg>.+) \((?P<logger>.+)\)"
test_str = ("[2023-10-24 20:33:14,925] DEBUG [Controller id=2] Topics not in preferred replica for broker 2 Map() (kafka.controller.KafkaController)\n"
"[2023-10-25 00:30:13,095] INFO [RaftManager nodeId=1] Disconnecting from node 2 due to request timeout. (org.apache.kafka.clients.NetworkClient)\n"
"[2023-10-25 00:01:39,422] INFO [RaftManager nodeId=1] Disconnecting from node 2 due to request timeout. (org.apache.kafka.clients.NetworkClient)")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.