const regex = new RegExp('\\[(?P<timestamp>\\d+-\\d{2}-\\d{2} \\d{2}:\\d{2}:\\d{2},\\d{3})\\] (?P<level>[A-Z]+) \\[(?P<context>.+?)\\] (?P<msg>.+) \\((?P<logger>.+)\\)', 'gm')
const str = `[2023-10-24 20:33:14,925] DEBUG [Controller id=2] Topics not in preferred replica for broker 2 Map() (kafka.controller.KafkaController)
[2023-10-25 00:30:13,095] INFO [RaftManager nodeId=1] Disconnecting from node 2 due to request timeout. (org.apache.kafka.clients.NetworkClient)
[2023-10-25 00:01:39,422] INFO [RaftManager nodeId=1] Disconnecting from node 2 due to request timeout. (org.apache.kafka.clients.NetworkClient)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}