use strict;
my $str = '<h3>COVEMA</h3>
<h3>PALMERO</h3>
<h3>PLASTIFERRO</h3>
<h3>UOCRA</h3>
<h3>REPAS</h3>
<h3>BTU</h3>
<h3>PANEDILE</h3>
<h3>ELEPRINT</h3>
<h3>JOSÉ J. CHEDIACK</h3>
<h3>NIRO CONSTRUCCIONES</h3>
<h3>HELPORT</h3>
<h3>BISCAYNE</h3>
<h3>COARCO</h3>
<h3>ESUCO</h3>
<h3>CPC</h3>
<h3>TEL 3</h3>
<h3>CARTELLONE</h3>
<h3>MACRO</h3>
<h3>VIAL AGRO</h3>
<h3>ISOLUX CORSÁN</h3>
<h3>AFCP</h3>
<h3>FINNING</h3>
<h3>ROGGIO</h3>
<h3>ROVELLA CARRANZA</h3>
<h3>ACINDAR</h3>
<h3>IERIC</h3>
<h3>IGARRETA MÁQUINAS</h3>
<h3>RIVA</h3>
<h3>GRUPO ESTISOL</h3>
<h3>IECSA</h3>
<h3>ARMAFERRO</h3>
<h3>BRICONS</h3>
<h3>CNH INDUSTRIAL</h3>
<h3>PAOLINI</h3>
<h3>SERVIUR</h3>
<h3>SANDVIK</h3>
<h3>DECAVIAL</h3>
<h3>ODEBRECHT</h3>
<h3>ENAS</h3>
<h3>SITRA</h3>
<h3>SUPERCEMENTO</h3>
<h3>JCR</h3>
<h3>CONSTRUMEX</h3>
<h3>BRIALES</h3>
<h3>CAPUTO</h3>
<h3>LUCIANO</h3>
<h3>GALICIA</h3>
<h3>VICTOR CONTRERAS</h3>
<h3>SIKA ARGENTINA</h3>
<h3>CRIBA</h3>
<h3>BOETTO Y BUTTIGLIENGO</h3>
<h3>MILICIC</h3>
<h3>PERIODICO EL CONSTRUCTOR</h3>
<h3>PHONERENTAL</h3>
<h3>DOS ARROYOS</h3>
<h3>MARTINEZ Y DE LA FUENTE</h3>
<h3>AUSA</h3>
<h3>LUIS LOSI</h3>
<h3>AESA</h3>
<h3>CONSTRUCTORA SUDAMERICANA</h3>
<h3>PLANTEL</h3>
<h3>PCR</h3>
<h3>BANCO DE LA NACIÓN ARGENTINA</h3>
<h3>SUBTERRÁNEOS DE BUENOS AIRES</h3>
<h3>HOLA SIM</h3>
<h3>JOSÉ LUIS TRIVIÑO</h3>
<h3>TECHINT</h3>
<h3>EDUARDO COLOMBI</h3>
<h3>ALEMARSA</h3>
<h3>CENTRO CONSTRUCCIONES</h3>
<h3>TECNIPISOS</h3>
<h3>XAPOR</h3>
<h3>FONTANA NICASTRO</h3>
<h3>CONCRET-NOR</h3>
<h3>DYCASA</h3>
<h3>BURGWARDT</h3>
<h3>SULLAIR</h3>
<h3>FONDO FIDUCIARIO FEDERAL DE INFRAESTRUCTURA REGIONAL</h3>
<h3>FLOWTEX</h3>
<h3>PETERSEN THIELE Y CRUZ</h3>
<h3>LIHUÉ</h3>
<h3>IRAM</h3>
<h3>ESTUDIO YMAZ</h3>
<h3>VIDOGAR</h3>
<h3>BICE</h3>
<h3>ROMERO CAMMISA</h3>
<h3>BATIMAT</h3>
<h3>ALBA CAUCIÓN</h3>
<h3>PROBA</h3>
<h3>ICF</h3>
<h3>TECMA</h3>
<h3>ALESTE</h3>
<h3>DELEGACIÓN PROVINCIA DE BUENOS AIRES</h3>
<h3>HIDRAVIAL</h3>
<h3>BANCO CIUDAD</h3>
<h3>LAMANNA</h3>';
my $regex = qr/(?<=\<h3\>).+(?=\<\/h3\>)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}