#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\<h3\>).+(?=\<\/h3\>)"
Local $sString = "<h3>COVEMA</h3>" & @CRLF & _
"<h3>PALMERO</h3>" & @CRLF & _
"<h3>PLASTIFERRO</h3>" & @CRLF & _
"<h3>UOCRA</h3>" & @CRLF & _
"<h3>REPAS</h3>" & @CRLF & _
"<h3>BTU</h3>" & @CRLF & _
"<h3>PANEDILE</h3>" & @CRLF & _
"<h3>ELEPRINT</h3>" & @CRLF & _
"<h3>JOSÉ J. CHEDIACK</h3>" & @CRLF & _
"<h3>NIRO CONSTRUCCIONES</h3>" & @CRLF & _
"<h3>HELPORT</h3>" & @CRLF & _
"<h3>BISCAYNE</h3>" & @CRLF & _
"<h3>COARCO</h3>" & @CRLF & _
"<h3>ESUCO</h3>" & @CRLF & _
"<h3>CPC</h3>" & @CRLF & _
"<h3>TEL 3</h3>" & @CRLF & _
"<h3>CARTELLONE</h3>" & @CRLF & _
"<h3>MACRO</h3>" & @CRLF & _
"<h3>VIAL AGRO</h3>" & @CRLF & _
"<h3>ISOLUX CORSÁN</h3>" & @CRLF & _
"<h3>AFCP</h3>" & @CRLF & _
"<h3>FINNING</h3>" & @CRLF & _
"<h3>ROGGIO</h3>" & @CRLF & _
"<h3>ROVELLA CARRANZA</h3>" & @CRLF & _
"<h3>ACINDAR</h3>" & @CRLF & _
"<h3>IERIC</h3>" & @CRLF & _
"<h3>IGARRETA MÁQUINAS</h3>" & @CRLF & _
"<h3>RIVA</h3>" & @CRLF & _
"<h3>GRUPO ESTISOL</h3>" & @CRLF & _
"<h3>IECSA</h3>" & @CRLF & _
"<h3>ARMAFERRO</h3>" & @CRLF & _
"<h3>BRICONS</h3>" & @CRLF & _
"<h3>CNH INDUSTRIAL</h3>" & @CRLF & _
"<h3>PAOLINI</h3>" & @CRLF & _
"<h3>SERVIUR</h3>" & @CRLF & _
"<h3>SANDVIK</h3>" & @CRLF & _
"<h3>DECAVIAL</h3>" & @CRLF & _
"<h3>ODEBRECHT</h3>" & @CRLF & _
"<h3>ENAS</h3>" & @CRLF & _
"<h3>SITRA</h3>" & @CRLF & _
"<h3>SUPERCEMENTO</h3>" & @CRLF & _
"<h3>JCR</h3>" & @CRLF & _
"<h3>CONSTRUMEX</h3>" & @CRLF & _
"<h3>BRIALES</h3>" & @CRLF & _
"<h3>CAPUTO</h3>" & @CRLF & _
"<h3>LUCIANO</h3>" & @CRLF & _
"<h3>GALICIA</h3>" & @CRLF & _
"<h3>VICTOR CONTRERAS</h3>" & @CRLF & _
"<h3>SIKA ARGENTINA</h3>" & @CRLF & _
"<h3>CRIBA</h3>" & @CRLF & _
"<h3>BOETTO Y BUTTIGLIENGO</h3>" & @CRLF & _
"<h3>MILICIC</h3>" & @CRLF & _
"<h3>PERIODICO EL CONSTRUCTOR</h3>" & @CRLF & _
"<h3>PHONERENTAL</h3>" & @CRLF & _
"<h3>DOS ARROYOS</h3>" & @CRLF & _
"<h3>MARTINEZ Y DE LA FUENTE</h3>" & @CRLF & _
"<h3>AUSA</h3>" & @CRLF & _
"<h3>LUIS LOSI</h3>" & @CRLF & _
"<h3>AESA</h3>" & @CRLF & _
"<h3>CONSTRUCTORA SUDAMERICANA</h3>" & @CRLF & _
"<h3>PLANTEL</h3>" & @CRLF & _
"<h3>PCR</h3>" & @CRLF & _
"<h3>BANCO DE LA NACIÓN ARGENTINA</h3>" & @CRLF & _
"<h3>SUBTERRÁNEOS DE BUENOS AIRES</h3>" & @CRLF & _
"<h3>HOLA SIM</h3>" & @CRLF & _
"<h3>JOSÉ LUIS TRIVIÑO</h3>" & @CRLF & _
"<h3>TECHINT</h3>" & @CRLF & _
"<h3>EDUARDO COLOMBI</h3>" & @CRLF & _
"<h3>ALEMARSA</h3>" & @CRLF & _
"<h3>CENTRO CONSTRUCCIONES</h3>" & @CRLF & _
"<h3>TECNIPISOS</h3>" & @CRLF & _
"<h3>XAPOR</h3>" & @CRLF & _
"<h3>FONTANA NICASTRO</h3>" & @CRLF & _
"<h3>CONCRET-NOR</h3>" & @CRLF & _
"<h3>DYCASA</h3>" & @CRLF & _
"<h3>BURGWARDT</h3>" & @CRLF & _
"<h3>SULLAIR</h3>" & @CRLF & _
"<h3>FONDO FIDUCIARIO FEDERAL DE INFRAESTRUCTURA REGIONAL</h3>" & @CRLF & _
"<h3>FLOWTEX</h3>" & @CRLF & _
"<h3>PETERSEN THIELE Y CRUZ</h3>" & @CRLF & _
"<h3>LIHUÉ</h3>" & @CRLF & _
"<h3>IRAM</h3>" & @CRLF & _
"<h3>ESTUDIO YMAZ</h3>" & @CRLF & _
"<h3>VIDOGAR</h3>" & @CRLF & _
"<h3>BICE</h3>" & @CRLF & _
"<h3>ROMERO CAMMISA</h3>" & @CRLF & _
"<h3>BATIMAT</h3>" & @CRLF & _
"<h3>ALBA CAUCIÓN</h3>" & @CRLF & _
"<h3>PROBA</h3>" & @CRLF & _
"<h3>ICF</h3>" & @CRLF & _
"<h3>TECMA</h3>" & @CRLF & _
"<h3>ALESTE</h3>" & @CRLF & _
"<h3>DELEGACIÓN PROVINCIA DE BUENOS AIRES</h3>" & @CRLF & _
"<h3>HIDRAVIAL</h3>" & @CRLF & _
"<h3>BANCO CIUDAD</h3>" & @CRLF & _
"<h3>LAMANNA</h3>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")