# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\[(?P<severity>\w+)\]\s*(?P<remote>[^\s:]+):(?P<port>\d+)\s*-\s*(?P<id>\d+)\s*\"(?P<type>[\w]+)\s*(?P<class>\w+)\s*(?P<name>[^\s]+)\s*(?P<proto>\w+)\s*(?P<size>\d+)\s*(?P<do>\w+)\s*(?P<bufsize>\d+)\"\s*(?P<rcode>\w+)\s*(?P<rflags>[^\s]+)\s+(?P<rsize>\d+)\s*(?P<duration>[^\s]+)"
test_str = ("[INFO] 172.20.164.61:52054 - 29029 \"AAAA IN private-link-api.coralogix.in. udp 47 false 512\" NOERROR qr,aa,rd,ra 163 0.000061739s\n"
"[INFO] 172.20.164.61:52054 - 15579 \"A IN private-link-api.coralogix.in.ap-south-1.compute.internal. udp 75 false 512\" NXDOMAIN qr,aa,rd,ra 190 0.000081757s\n\n"
"[INFO] 172.20.164.61:52054 - 15579 \"A IN private-link-api.coralogix.in.ap-south-1.compute.internal. udp 75 false 512\" NXDOMAIN aa,rd,ra 190 0.000081757s\n\n"
"[INFO] 172.20.160.191:44146 - 254 \\\"A IN secretsmanager.ap-south-1.amazonaws.com. udp 57 false 512\\\" NOERROR qr,aa,rd,ra 222 0.000054345s\\n\",\"time\":\"2023-02-13T12:14:26.928909225Z")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.