using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(?P<severity>\w+)\]\s*(?P<remote>[^\s:]+):(?P<port>\d+)\s*-\s*(?P<id>\d+)\s*""(?P<type>[\w]+)\s*(?P<class>\w+)\s*(?P<name>[^\s]+)\s*(?P<proto>\w+)\s*(?P<size>\d+)\s*(?P<do>\w+)\s*(?P<bufsize>\d+)""\s*(?P<rcode>\w+)\s*(?P<rflags>[^\s]+)\s+(?P<rsize>\d+)\s*(?P<duration>[^\s]+)";
string input = @"[INFO] 172.20.164.61:52054 - 29029 ""AAAA IN private-link-api.coralogix.in. udp 47 false 512"" NOERROR qr,aa,rd,ra 163 0.000061739s
[INFO] 172.20.164.61:52054 - 15579 ""A IN private-link-api.coralogix.in.ap-south-1.compute.internal. udp 75 false 512"" NXDOMAIN qr,aa,rd,ra 190 0.000081757s
[INFO] 172.20.164.61:52054 - 15579 ""A IN private-link-api.coralogix.in.ap-south-1.compute.internal. udp 75 false 512"" NXDOMAIN aa,rd,ra 190 0.000081757s
[INFO] 172.20.160.191:44146 - 254 \""A IN secretsmanager.ap-south-1.amazonaws.com. udp 57 false 512\"" NOERROR qr,aa,rd,ra 222 0.000054345s\n"",""time"":""2023-02-13T12:14:26.928909225Z";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}