import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "lat";
final String string = "# Degrees minutes\n"
+ "# \\d+\\W+\\d+\\W+\\d+\\.?\\d*\n\n"
+ "\"-77.566296, 41.471044\"\n"
+ "5234098, 29384\n\n"
+ "40° 37' 03.620\\\" N\n\n"
+ " 39.9153 N 78.3405 W\n\n\n"
+ "CORNPLANTER BRIDGE QUAD.--LAT. 41-48-18.41--LONG. -78-52-51.26\n"
+ "LUDLOW QUAD--LAT.41-39-16.0500--LONG.-78-55-11.1200\n"
+ "LAT 41-45-00 LONG 75-50-00\n"
+ "LAT 41.73381944 LONG -75.87685278\n"
+ "Ref Latitude 41 81833 - Ref Longitude -75 15167\n"
+ "LAT 41 56' 11.28\\\" N--LON 76 52' 03.36\\\" W\n\n"
+ "[891] \"McNett TOWNSHIP\" \n"
+ "[892] \"TWP - Range - Sec\" \n"
+ "[893] \"MONETT TOWNSHIP,LYCOMING COUNTY,PA\n"
+ "LAT 41 42 12.6700\n"
+ "LAT 41 DEG 43-52-0300 \n"
+ "LAT 41.4122917\n"
+ "Latitude: 40.752 N\n"
+ "Lat. 40.72617600* N\n"
+ "Longitude: 80-24-41 W\n"
+ "Latitude: 40.653407 N\n"
+ "LAT: 40.687574\n"
+ "LAT\n"
+ "LAT: 40-50-13.7000\n"
+ "Latitude: 40.83721N\n"
+ "LATITUDE\n"
+ "Latitude 39-53-12.33 N\n"
+ "LATITUDE 39-53.442319 N\n"
+ "Latitude 39-53-43.26 N\n"
+ "Latitude 39.8949 N\n"
+ "LAT: 41-43-26.9600 N\n"
+ "LAT: 41-43-29.83\n"
+ "LAT: 41*51'42.99\\\" N\n"
+ "LAT: 41-46-9.8700 N\n"
+ "LATITUDE: 41* 42' 40.19\\\"\n\n"
+ "41-42-40.19 LAT\n\n"
+ "API # 37-015-208801-00--X=2201217.34E Y=632183.50N--LAT\"\n"
+ "03-029-01";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}