#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)lat"
Local $sString = "# Degrees minutes" & @CRLF & _
"# \d+\W+\d+\W+\d+\.?\d*" & @CRLF & _
"" & @CRLF & _
""-77.566296, 41.471044"" & @CRLF & _
"5234098, 29384" & @CRLF & _
"" & @CRLF & _
"40° 37' 03.620\" N" & @CRLF & _
"" & @CRLF & _
" 39.9153 N 78.3405 W" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"CORNPLANTER BRIDGE QUAD.--LAT. 41-48-18.41--LONG. -78-52-51.26" & @CRLF & _
"LUDLOW QUAD--LAT.41-39-16.0500--LONG.-78-55-11.1200" & @CRLF & _
"LAT 41-45-00 LONG 75-50-00" & @CRLF & _
"LAT 41.73381944 LONG -75.87685278" & @CRLF & _
"Ref Latitude 41 81833 - Ref Longitude -75 15167" & @CRLF & _
"LAT 41 56' 11.28\" N--LON 76 52' 03.36\" W" & @CRLF & _
"" & @CRLF & _
"[891] "McNett TOWNSHIP" " & @CRLF & _
"[892] "TWP - Range - Sec" " & @CRLF & _
"[893] "MONETT TOWNSHIP,LYCOMING COUNTY,PA" & @CRLF & _
"LAT 41 42 12.6700" & @CRLF & _
"LAT 41 DEG 43-52-0300 " & @CRLF & _
"LAT 41.4122917" & @CRLF & _
"Latitude: 40.752 N" & @CRLF & _
"Lat. 40.72617600* N" & @CRLF & _
"Longitude: 80-24-41 W" & @CRLF & _
"Latitude: 40.653407 N" & @CRLF & _
"LAT: 40.687574" & @CRLF & _
"LAT" & @CRLF & _
"LAT: 40-50-13.7000" & @CRLF & _
"Latitude: 40.83721N" & @CRLF & _
"LATITUDE" & @CRLF & _
"Latitude 39-53-12.33 N" & @CRLF & _
"LATITUDE 39-53.442319 N" & @CRLF & _
"Latitude 39-53-43.26 N" & @CRLF & _
"Latitude 39.8949 N" & @CRLF & _
"LAT: 41-43-26.9600 N" & @CRLF & _
"LAT: 41-43-29.83" & @CRLF & _
"LAT: 41*51'42.99\" N" & @CRLF & _
"LAT: 41-46-9.8700 N" & @CRLF & _
"LATITUDE: 41* 42' 40.19\"" & @CRLF & _
"" & @CRLF & _
"41-42-40.19 LAT" & @CRLF & _
"" & @CRLF & _
"API # 37-015-208801-00--X=2201217.34E Y=632183.50N--LAT"" & @CRLF & _
"03-029-01"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")