re = /^((?!gtm\.).*)$
/m
str = 'signup_success
gtm.js
gtm.load
gtm.dom
gtm.historyChange
bet_placed
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end