$re = '/^((?!gtm\.).*)$
/m';
$str = 'signup_success
gtm.js
gtm.load
gtm.dom
gtm.historyChange
bet_placed
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);