import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(((\\*|(\\d\\d?))(\\/\\d\\d?)?)|(\\d\\d?\\-\\d\\d?))(,(((\\*|(\\d\\d?))(\\/\\d\\d?)?)|(\\d\\d?\\-\\d\\d?)))*\\s(((\\*|(\\d\\d?))(\\/\\d\\d?)?)|(\\d\\d?\\-\\d\\d?))(,(((\\*|(\\d\\d?))(\\/\\d\\d?)?)|(\\d\\d?\\-\\d\\d?)))*\\s(((\\*|(\\d\\d?))(\\/\\d\\d?)?)|(\\d\\d?\\-\\d\\d?))(,(((\\*|(\\d\\d?))(\\/\\d\\d?)?)|(\\d\\d?\\-\\d\\d?)))*\\s(\\?|(((\\*|(\\d\\d?L?))(\\/\\d\\d?)?)|(\\d\\d?L?\\-\\d\\d?L?)|L|(\\d\\d?W))(,(((\\*|(\\d\\d?L?))(\\/\\d\\d?)?)|(\\d\\d?L?\\-\\d\\d?L?)|L|(\\d\\d?W)))*)\\s(((\\*|(\\d|10|11|12|JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC))(\\/\\d\\d?)?)|((\\d|10|11|12|JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC)\\-(\\d|10|11|12|JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC)))(,(((\\*|(\\d|10|11|12|JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC))(\\/\\d\\d?)?)|((\\d|10|11|12|JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC)\\-(\\d|10|11|12|JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC))))*\\s(((\\*|([0-7]|MON|TUE|WED|THU|FRI|SAT|SUN)L?)(\\/\\d\\d?)?)|(([0-7]|MON|TUE|WED|THU|FRI|SAT|SUN)L?\\-([0-7]|MON|TUE|WED|THU|FRI|SAT|SUN)L?)|([0-7]|MON|TUE|WED|THU|FRI|SAT|SUN)L?#([1-5]))(,(((\\*|([0-7]|MON|TUE|WED|THU|FRI|SAT|SUN)L?)(\\/\\d\\d?)?)|(([0-7]|MON|TUE|WED|THU|FRI|SAT|SUN)L?\\-([0-7]|MON|TUE|WED|THU|FRI|SAT|SUN)L?)|([0-7]|MON|TUE|WED|THU|FRI|SAT|SUN)L?#([1-5])))*$";
final String string = "* * * * * *\n"
+ "* * * * * *\n"
+ "* * * * * *\n"
+ "3 * * * * *\n"
+ "3 * * * * *\n"
+ "3 * * * * *\n"
+ "3 * * * * *\n"
+ "3 * * * * *\n"
+ "5/15 * * * * *\n"
+ "5/15 * * * * *\n"
+ "5/15 * * * * *\n"
+ "5/15 * * * * *\n"
+ "5/15 * * * * *\n"
+ "7,19 * * * * *\n"
+ "7,19 * * * * *\n"
+ "7,19 * * * * *\n"
+ "2-45 * * * * *\n"
+ "2-4 * * * * *\n"
+ "42-45 * * * * *\n"
+ "42-45 * * * * *\n"
+ "42-45 * * * * *\n"
+ "42-45 * * * * *\n"
+ "42-63 * * * * *\n"
+ "0 3 * * * *\n"
+ "0 3 * * * *\n"
+ "0 0/15 * * * *\n"
+ "0 0/15 * * * *\n"
+ "0 0/15 * * * *\n"
+ "0 0/15 * * * *\n"
+ "0 7,19 * * * *\n"
+ "0 7,19 * * * *\n"
+ "0 * 3 * * *\n"
+ "0 * 3 * * *\n"
+ "0 * 3 * * *\n"
+ "0 * 0/15 * * *\n"
+ "0 * 0/15 * * *\n"
+ "0 * 0/15 * * *\n"
+ "0 * 0/15 * * *\n"
+ "0 * 0/15 * * *\n"
+ "0 * 7,19 * * *\n"
+ "0 * 7,19 * * *\n"
+ "0 * 7,19 * * *\n"
+ "0 1 * * * *\n"
+ "0 0 * * * *\n"
+ "0 * * 3 * *\n"
+ "0 * * 3 * *\n"
+ "0 * * 3 * *\n"
+ "0 * * 3 * *\n"
+ "0 0 0 1/15 * *\n"
+ "0 0 0 1/15 * *\n"
+ "0 0 0 1/15 * *\n"
+ "0 0 0 1/15 * *\n"
+ "0 0 0 7,19 * *\n"
+ "0 0 0 7,19 * *\n"
+ "0 0 0 7,19 * *\n"
+ "0 0 0 7,19 * *\n"
+ "0 0 0 L * *\n"
+ "0 0 0 L * *\n"
+ "0 0 0 3L * *\n"
+ "0 0 0 3L * *\n"
+ "0 0 0 9W * *\n"
+ "0 0 0 9W * *\n"
+ "0 0 0 9W * *\n"
+ "0 0 0 9W * *\n"
+ "0 0 0 9X */2 *\n"
+ "0 0 0 9#2 * *\n"
+ "0 0 0 1 5 *\n"
+ "0 0 0 1 5/2 *\n"
+ "0 0 0 1 5/2 *\n"
+ "0 0 0 1 5/10 *\n"
+ "0 0 0 1 3,7,12 *\n"
+ "0 0 0 1 3,7,12 *\n"
+ "0 0 0 1 3,7,12 *\n"
+ "0 0 0 1 MAR,JUL,DEC *\n"
+ "0 0 0 1 MAR,JUL,DEC *\n"
+ "0 0 0 1 MAR,JUL,DEC *\n"
+ "0 0 0 1 ? *\n"
+ "0 0 0 * * 3\n"
+ "0 0 0 * * 3\n"
+ "0 0 0 * * 3\n"
+ "0 0 0 * * 3\n"
+ "0 0 0 * * 3/2\n"
+ "0 0 0 * * 3/2\n"
+ "0 0 0 * * 3/2\n"
+ "0 0 0 * * 3/2\n"
+ "0 0 0 * * 1,5,7\n"
+ "0 0 0 * * 1,5,7\n"
+ "0 0 0 * * 1,5,7\n"
+ "0 0 0 * * MON,FRI,SUN\n"
+ "0 0 0 * * MON,FRI,SUN\n"
+ "0 0 0 * * MON,FRI,SUN\n"
+ "0 0 0 * * 5L\n"
+ "0 0 0 * * 5L\n"
+ "0 0 0 * * 5L\n"
+ "0 0 0 * * FRIL\n"
+ "0 0 0 * * 5W\n"
+ "0 0 0 * * 5?3\n"
+ "0 0 0 * * 0\n"
+ "0 0 0 * * 0L\n"
+ "0 0 0 * * 0#2\n"
+ "0 0 0 * * 7\n"
+ "0 0 0 * * 7L\n"
+ "0 0 0 * * 7#2\n"
+ "0 0 0 * * 5#3\n"
+ "0 0 0 * * 5#3\n"
+ "0 0 0 * * 7#1\n"
+ "0 0 0 * * 7#1\n"
+ "0 0 0 * * 3#5\n"
+ "0 0 0 * * WED#5\n"
+ "* * 5-1 * * *";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}