#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(((\*|(\d\d?))(\/\d\d?)?)|(\d\d?\-\d\d?))(,(((\*|(\d\d?))(\/\d\d?)?)|(\d\d?\-\d\d?)))*\s(((\*|(\d\d?))(\/\d\d?)?)|(\d\d?\-\d\d?))(,(((\*|(\d\d?))(\/\d\d?)?)|(\d\d?\-\d\d?)))*\s(((\*|(\d\d?))(\/\d\d?)?)|(\d\d?\-\d\d?))(,(((\*|(\d\d?))(\/\d\d?)?)|(\d\d?\-\d\d?)))*\s(\?|(((\*|(\d\d?L?))(\/\d\d?)?)|(\d\d?L?\-\d\d?L?)|L|(\d\d?W))(,(((\*|(\d\d?L?))(\/\d\d?)?)|(\d\d?L?\-\d\d?L?)|L|(\d\d?W)))*)\s(((\*|(\d|10|11|12|JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC))(\/\d\d?)?)|((\d|10|11|12|JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC)\-(\d|10|11|12|JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC)))(,(((\*|(\d|10|11|12|JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC))(\/\d\d?)?)|((\d|10|11|12|JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC)\-(\d|10|11|12|JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC))))*\s(((\*|([0-7]|MON|TUE|WED|THU|FRI|SAT|SUN)L?)(\/\d\d?)?)|(([0-7]|MON|TUE|WED|THU|FRI|SAT|SUN)L?\-([0-7]|MON|TUE|WED|THU|FRI|SAT|SUN)L?)|([0-7]|MON|TUE|WED|THU|FRI|SAT|SUN)L?#([1-5]))(,(((\*|([0-7]|MON|TUE|WED|THU|FRI|SAT|SUN)L?)(\/\d\d?)?)|(([0-7]|MON|TUE|WED|THU|FRI|SAT|SUN)L?\-([0-7]|MON|TUE|WED|THU|FRI|SAT|SUN)L?)|([0-7]|MON|TUE|WED|THU|FRI|SAT|SUN)L?#([1-5])))*$"
Local $sString = "* * * * * *" & @CRLF & _
"* * * * * *" & @CRLF & _
"* * * * * *" & @CRLF & _
"3 * * * * *" & @CRLF & _
"3 * * * * *" & @CRLF & _
"3 * * * * *" & @CRLF & _
"3 * * * * *" & @CRLF & _
"3 * * * * *" & @CRLF & _
"5/15 * * * * *" & @CRLF & _
"5/15 * * * * *" & @CRLF & _
"5/15 * * * * *" & @CRLF & _
"5/15 * * * * *" & @CRLF & _
"5/15 * * * * *" & @CRLF & _
"7,19 * * * * *" & @CRLF & _
"7,19 * * * * *" & @CRLF & _
"7,19 * * * * *" & @CRLF & _
"2-45 * * * * *" & @CRLF & _
"2-4 * * * * *" & @CRLF & _
"42-45 * * * * *" & @CRLF & _
"42-45 * * * * *" & @CRLF & _
"42-45 * * * * *" & @CRLF & _
"42-45 * * * * *" & @CRLF & _
"42-63 * * * * *" & @CRLF & _
"0 3 * * * *" & @CRLF & _
"0 3 * * * *" & @CRLF & _
"0 0/15 * * * *" & @CRLF & _
"0 0/15 * * * *" & @CRLF & _
"0 0/15 * * * *" & @CRLF & _
"0 0/15 * * * *" & @CRLF & _
"0 7,19 * * * *" & @CRLF & _
"0 7,19 * * * *" & @CRLF & _
"0 * 3 * * *" & @CRLF & _
"0 * 3 * * *" & @CRLF & _
"0 * 3 * * *" & @CRLF & _
"0 * 0/15 * * *" & @CRLF & _
"0 * 0/15 * * *" & @CRLF & _
"0 * 0/15 * * *" & @CRLF & _
"0 * 0/15 * * *" & @CRLF & _
"0 * 0/15 * * *" & @CRLF & _
"0 * 7,19 * * *" & @CRLF & _
"0 * 7,19 * * *" & @CRLF & _
"0 * 7,19 * * *" & @CRLF & _
"0 1 * * * *" & @CRLF & _
"0 0 * * * *" & @CRLF & _
"0 * * 3 * *" & @CRLF & _
"0 * * 3 * *" & @CRLF & _
"0 * * 3 * *" & @CRLF & _
"0 * * 3 * *" & @CRLF & _
"0 0 0 1/15 * *" & @CRLF & _
"0 0 0 1/15 * *" & @CRLF & _
"0 0 0 1/15 * *" & @CRLF & _
"0 0 0 1/15 * *" & @CRLF & _
"0 0 0 7,19 * *" & @CRLF & _
"0 0 0 7,19 * *" & @CRLF & _
"0 0 0 7,19 * *" & @CRLF & _
"0 0 0 7,19 * *" & @CRLF & _
"0 0 0 L * *" & @CRLF & _
"0 0 0 L * *" & @CRLF & _
"0 0 0 3L * *" & @CRLF & _
"0 0 0 3L * *" & @CRLF & _
"0 0 0 9W * *" & @CRLF & _
"0 0 0 9W * *" & @CRLF & _
"0 0 0 9W * *" & @CRLF & _
"0 0 0 9W * *" & @CRLF & _
"0 0 0 9X */2 *" & @CRLF & _
"0 0 0 9#2 * *" & @CRLF & _
"0 0 0 1 5 *" & @CRLF & _
"0 0 0 1 5/2 *" & @CRLF & _
"0 0 0 1 5/2 *" & @CRLF & _
"0 0 0 1 5/10 *" & @CRLF & _
"0 0 0 1 3,7,12 *" & @CRLF & _
"0 0 0 1 3,7,12 *" & @CRLF & _
"0 0 0 1 3,7,12 *" & @CRLF & _
"0 0 0 1 MAR,JUL,DEC *" & @CRLF & _
"0 0 0 1 MAR,JUL,DEC *" & @CRLF & _
"0 0 0 1 MAR,JUL,DEC *" & @CRLF & _
"0 0 0 1 ? *" & @CRLF & _
"0 0 0 * * 3" & @CRLF & _
"0 0 0 * * 3" & @CRLF & _
"0 0 0 * * 3" & @CRLF & _
"0 0 0 * * 3" & @CRLF & _
"0 0 0 * * 3/2" & @CRLF & _
"0 0 0 * * 3/2" & @CRLF & _
"0 0 0 * * 3/2" & @CRLF & _
"0 0 0 * * 3/2" & @CRLF & _
"0 0 0 * * 1,5,7" & @CRLF & _
"0 0 0 * * 1,5,7" & @CRLF & _
"0 0 0 * * 1,5,7" & @CRLF & _
"0 0 0 * * MON,FRI,SUN" & @CRLF & _
"0 0 0 * * MON,FRI,SUN" & @CRLF & _
"0 0 0 * * MON,FRI,SUN" & @CRLF & _
"0 0 0 * * 5L" & @CRLF & _
"0 0 0 * * 5L" & @CRLF & _
"0 0 0 * * 5L" & @CRLF & _
"0 0 0 * * FRIL" & @CRLF & _
"0 0 0 * * 5W" & @CRLF & _
"0 0 0 * * 5?3" & @CRLF & _
"0 0 0 * * 0" & @CRLF & _
"0 0 0 * * 0L" & @CRLF & _
"0 0 0 * * 0#2" & @CRLF & _
"0 0 0 * * 7" & @CRLF & _
"0 0 0 * * 7L" & @CRLF & _
"0 0 0 * * 7#2" & @CRLF & _
"0 0 0 * * 5#3" & @CRLF & _
"0 0 0 * * 5#3" & @CRLF & _
"0 0 0 * * 7#1" & @CRLF & _
"0 0 0 * * 7#1" & @CRLF & _
"0 0 0 * * 3#5" & @CRLF & _
"0 0 0 * * WED#5" & @CRLF & _
"* * 5-1 * * *"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")