$re = '/^\d{3}-\d{3}-\d{4}$/m';
$str = '616-555-1212
555-1212
6165551212
asdf
1
800-111-2222
800-111-2222d
800-11a-2222
.
112
-
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);