import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d{3}-\\d{3}-\\d{4}$";
final String string = "616-555-1212\n"
+ "555-1212\n"
+ "6165551212\n"
+ "asdf\n"
+ "1\n"
+ "800-111-2222\n"
+ "800-111-2222d\n"
+ "800-11a-2222\n"
+ ".\n"
+ "112\n"
+ "-\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}