re = /([0-9]*)\.([0-9]*)N,( *)([0-9]*)\.([0-9]*)E/
str = '50.4740817N, 14.5416525E'
# Print the match result
str.match(re) do |match|
puts match.to_s
end