package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([0-9]*)\.([0-9]*)N,( *)([0-9]*)\.([0-9]*)E`)
var str = `50.4740817N, 14.5416525E`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}