$re = '/[ ]+(incorporation|\binc[.]*(?!\w))/mi';
$str = 'Inc
Inc.
Incorporation
My Inc
My Inc.
My Inc. Company
My Incorporation company
Linc Communication Llc
DRV Incorporated';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);