using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[ ]+(incorporation|\binc[.]*(?!\w))";
string input = @"Inc
Inc.
Incorporation
My Inc
My Inc.
My Inc. Company
My Incorporation company
Linc Communication Llc
DRV Incorporated";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}