import Foundation
let pattern = #"^20(((([248][048])|([13579][26]))\/(((0[13578]|1[02])\/([0-2][0-9]|3[01]))|((0[469]|11)\/([0-2][0-9]|30))|(02\/([0-2][0-9]))))|((([248][1-35-79])|([13579][013-57-9]))\/(((0[13578]|1[02])\/([0-2][0-9]|3[01]))|((0[469]|11)\/([0-2][0-9]|30))|(02\/(((0|1)[0-9])|(2[0-8]))))))$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"2015/02/28"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}