import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^20(((([248][048])|([13579][26]))\\/(((0[13578]|1[02])\\/([0-2][0-9]|3[01]))|((0[469]|11)\\/([0-2][0-9]|30))|(02\\/([0-2][0-9]))))|((([248][1-35-79])|([13579][013-57-9]))\\/(((0[13578]|1[02])\\/([0-2][0-9]|3[01]))|((0[469]|11)\\/([0-2][0-9]|30))|(02\\/(((0|1)[0-9])|(2[0-8]))))))$";
final String string = "2015/02/28";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}