import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:\\d|[1-9]\\d|1\\d\\d|2[0-4]\\d|25[0-5])\\.){3}(?:\\d|[1-9]\\d|1\\d\\d|2[0-4]\\d|25[0-5])$";
final String string = "0.0.0.0\n"
+ "1.1.1.1\n"
+ "9.9.9.9\n"
+ "10.10.10.10\n"
+ "99.99.99.99\n"
+ "100.100.100.100\n"
+ "199.199.199.199\n"
+ "200.200.200.200\n"
+ "255.255.255.255\n\n"
+ "256.256.256.256\n"
+ "1.1.1.1.1\n"
+ "foo.bar.baz.qux";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}