package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(?:\d|[1-9]\d|1\d\d|2[0-4]\d|25[0-5])\.){3}(?:\d|[1-9]\d|1\d\d|2[0-4]\d|25[0-5])$`)
var str = `0.0.0.0
1.1.1.1
9.9.9.9
10.10.10.10
99.99.99.99
100.100.100.100
199.199.199.199
200.200.200.200
255.255.255.255
256.256.256.256
1.1.1.1.1
foo.bar.baz.qux`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}