$re = '/(\\\\+|\/+|\d)/';
$str = 'Jase\\áéýľščť+nov8,`; \\ 12345/67éíáýžť890 []/ťžčťg2340\\()';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);