re = /^(?<User>[_a-z0-9-]+(\.[_a-z0-9-]+(?<GmailTag>\+[_a-z0-9-]+){1,1})*)@(?<Host>[a-z0-9-]+(\.[a-z0-9-]+)*\.[a-z]{2,4})$/i
str = 'kevimetal.matyrock+pruebasdecolegios@google.mail.com'
# Print the match result
str.match(re) do |match|
puts match.to_s
end