const regex = /^(?<User>[_a-z0-9-]+(\.[_a-z0-9-]+(?<GmailTag>\+[_a-z0-9-]+){1,1})*)@(?<Host>[a-z0-9-]+(\.[a-z0-9-]+)*\.[a-z]{2,4})$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<User>[_a-z0-9-]+(\\.[_a-z0-9-]+(?<GmailTag>\\+[_a-z0-9-]+){1,1})*)@(?<Host>[a-z0-9-]+(\\.[a-z0-9-]+)*\\.[a-z]{2,4})$', 'i')
const str = `kevimetal.matyrock+pruebasdecolegios@google.mail.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}