use strict;
my $str = 'sample-search-cdn|nz|nz--cdn|||||generic-produce-luxury-gdn|||generic-value|||| ';
my $regex = qr/^([^\s\|]+)\|([^\|]+)\|([^\|]+)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";