import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^\\s\\|]+)\\|([^\\|]+)\\|([^\\|]+)";
final String string = "sample-search-cdn|nz|nz--cdn|||||generic-produce-luxury-gdn|||generic-value|||| ";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}