const regex = /(?:http:\/\/)?(?:www\.)?(.*?)\/(.+?)(?:\/|\?|\#|$|\n)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:http:\\\/\\\/)?(?:www\\.)?(.*?)\\\/(.+?)(?:\\\/|\\?|\\#|$|\\n)', 'g')
const str = `http://www.site.com/valid_uri?query=string#hash
http://www.site.com/valid_uri?query=string#hash
www.site.com/valid_uri?query=string
site.com/valid_uri?query=string
bolsademulher.com/valid_uri
bolsademulher.com/
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}