import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:http:\\/\\/)?(?:www\\.)?(.*?)\\/(.+?)(?:\\/|\\?|\\#|$|\\n)";
final String string = "http://www.site.com/valid_uri?query=string#hash\n"
+ "http://www.site.com/valid_uri?query=string#hash\n"
+ "www.site.com/valid_uri?query=string\n"
+ "site.com/valid_uri?query=string\n"
+ "bolsademulher.com/valid_uri\n"
+ "bolsademulher.com/\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}