$re = '/[(\&&?)]?([^=]+)(==|!=|>=|<=)([^&#]+)(&&|\|\|)?/';
$str = 'BuilderPromo.builder_id==6&&request.id==6';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);